Full Screen Home

Link กันไป Link กันมา

ตามปกติเมื่อใช้วิธี Pointing สร้างสูตร link ข้าม sheet จะพบว่าสูตรที่สร้างขึ้นแตกต่างจาก สูตร link ข้าม file กล่าวคือ สูตร link ข้าม sheet ที่ได้จะอยู่ในลักษณะ relative reference ไม่มีเครื่องหมาย $ ส่วนสูตรที่ได้จากสูตร link ข้าม file ที่ได้จะอยู่ในลักษณะ absolute reference มีเครื่องหมาย $ ควบคุมทั้ง row และ column

ในกรณีสูตร link ข้าม file นั้น เนื่องจากเป็น absolute reference ดังนั้นหากต้องการ link ค่าจากเซลล์อื่นๆ ซึ่งอยู่ใกล้เคียงกับตำแหน่งเดิมที่ link มา จะต้องเปลี่ยนให้เป็นสูตรแบบ relative เสียก่อน จากนั้นจึงใช้วิธี copy แล้ว paste ไปยังเซลล์อื่น จะได้สูตร link ข้าม file จากเซลล์เหล่านั้นโดยอัตโนมัติ เนื่องจากการ copy สูตรแบบ relative reference ทำให้ตำแหน่งอ้างอิงเปลี่ยนสัมพัทธ์กับตำแหน่งแรกเรื่อยๆไป

จุดอ่อนของการสร้างสูตรด้วยวิธี Pointing คือ เราสามารถสร้างสูตร link ได้ทีละเซลล์ แล้วค่อยใช้วิธี copy ต่อๆกันไป

นอกจากวิธีดังกล่าว Excel ยังมีวิธีลัดตัดตอน ใช้สร้างสูตร link กันทีละหลายๆเซลล์ เรียกว่า สร้างสูตร link กันทีเดียวทั้งตารางเลยยังได้ โดยเลือกใช้ 2 วิธีต่อไปนี้

  1. Copy แล้วสั่ง Paste Special เลือกแบบ Paste Link จะได้สูตร link ทุกเซลล์ที่เลือก
  2. Cut สูตรที่สร้างไว้ใน sheet ต้นทาง แล้วสั่ง Paste ลงไปใน sheet ปลายทาง จะทำให้สูตรกลายเป็นสูตร link

จากวิธีที่ 2 จะเห็นได้ว่า เราไม่จำเป็นต้องสร้างสูตร link ข้ามไปข้ามมา ตอนที่กำลังสร้างงานอยู่หรอก แต่ให้สร้างตารางซึ่งกะว่า น่าจะไปอยู่คนละ sheet สร้างลงใน sheet เดิม file เดิมที่ใช้งานอยู่นี่แหละ ช่วยให้ใช้เวลาสร้างลดลงไปเยอะ เพราะไม่ต้องกลับ sheet หรือ file สลับไปสลับมา พอสร้างตารางเสร็จก็ให้จัดการสั่ง Cut ไป Paste ที่ sheet อื่น file อื่น ทีเดียวทั้งตารางเลย 

วิธีแก้ไขสูตร Link

เราสามารถใช้เมนูคำสั่ง Edit > Replace แก้ไขสูตร link ได้เช่นเดียวกันกับการแก้ไขสูตรทั่วๆไป และต้องระวังการสั่ง Replace All ให้ดี เพราะถ้าหากเราเลือกเซลล์เพียงเซลล์เดียว จะเท่ากับเป็นการสั่งให้ Replace All สูตรที่อยู่ในเซลล์ทุกเซลล์พร้อมกันทั้งหมดใน sheet นั้นๆ ดังนั้นหากต้องการสั่ง Replace All เฉพาะเซลล์ใดเซลล์หนึ่ง ต้องเลือกเซลล์อย่างน้อย 2 เซลล์ขึ้นไปก่อน แล้วจึงสั่ง Replace All เพื่อเปลี่ยนแปลงสูตรเฉพาะเซลล์ที่เลือกไว้เท่านั้น

สำหรับวิธีเปลี่ยนแปลงแก้ไขสูตร link ข้าม file ยังมีวิธีลัดเหนือกว่าวิธี Edit > Replace โดยสั่ง Edit > Links > เลือกชื่อ Source file เดิม แล้วกดปุ่ม Change Sources ไปค้นหาชื่อ file ใหม่ซึ่งต้องการให้สูตร link เปลี่ยนตำแหน่งการอ้างอิงจาก file เดิมไปยัง file ใหม่

วิธีนี้จะเปลี่ยนสูตร link ข้าม file ทุกสูตรในทุก sheet จากการใช้ชื่อ file เดิมไปเป็นชื่อ file ใหม่ให้เองโดยอัตโนมัติ โดยยังคงตำแหน่งอ้างอิงระดับ sheet และ เซลล์ไว้คงเดิมไม่เปลี่ยนแปลง ดังนั้น file เดิม และ file ใหม่ ต้องมีค่าใน sheet และ เซลล์ตรงกัน จึงจะทำให้ได้ค่าจาก file ใหม่ไปใช้แทน

วิธีรักษาสูตร Link

หลักสำคัญซึ่งพึงระมัดระวังในการรักษาสูตร link ข้าม file ให้สามารถนำค่าที่ต้องการมาใช้งานได้ถูกต้อง มีดังนี้

  1. ให้ save source file ซึ่งเป็นต้นทางของข้อมูลก่อน แล้วจึงสั่ง save target file ซึ่งรับค่ามาใช้งานทีหลัง เพื่อทำให้สูตร link จำตำแหน่งที่ link มาได้ถูกต้อง ไม่ว่าจะ save เปลี่ยนชื่อ source file ย้ายสถานที่เก็บไปยัง directory/folder ต่างไปจากเดิมก็ตาม

  2. หากต้องการ insert/delete/rename cell/row/column/sheet ให้เปิด file ทุก file ที่ link กันขึ้นมาก่อน แล้วจึงสั่งเปลี่ยนแปลงแก้ไขดังกล่าว เพื่อให้ตำแหน่งในสูตร link เปลี่ยนแปลงแก้ไขตามไปโดยอัตโนมัติ แล้วจึงสั่ง save ตามหลักข้อ 1

วิธีแกะสูตร Link มีหลายวิธี เช่น

  1. Double คลิกที่เซลล์สูตร จะทำให้ Excel เลือกเซลล์ต้นทางที่มาของค่า ถ้าเป็นสูตร link ข้าม sheet จะทำให้ Excel เลือก sheet ต้นทางและเซลล์ต้นทางใน sheet นั้นให้ หากเป็นสูตร link ข้าม file เมื่อ double คลิก จะทำให้ Excel เปิด file ต้นทางให้ทันที แล้วเลือกเซลล์ต้นทางให้ด้วย

  2. ใช้เมนูคำสั่ง Edit > Links > Open Source จะเปิด file ซึ่งเป็นต้นทาง ใช้ในกรณีที่สร้างสูตร link ข้าม file

  3. กดปุ่ม F5 > Special > Precedents เพื่อไปที่เซลล์ต้นทาง หากเลือก Dependents จะไปที่เซลล์ปลายทางซึ่งรับค่าจากเซลล์ต้นทางไปใช้

  4. ใช้เมนูคำสั่ง Tools > Auditing แล้วเลือกค้นหา Trace Precedents/Dependents โดย Excel จะสร้างเส้นลูกศรชี้ไปยังเซลล์ปลายทาง หาก double คลิกที่เส้นลูกศรนี้ จะช่วยเลือกเซลล์ต้นทางสลับกับปลายทางให้ทุกครั้งที่ double คลิกที่เส้น auditing

    เราสามารถสั่งพิมพ์เส้นลูกศร เพื่อใช้เป็นเสมือนแผนที่แสดงความสัมพันธ์ของสูตรต่างๆ แต่เราไม่สามารถเก็บเส้นลูกศรไว้ได้ เพราะเมื่อสั่ง save file จะทำให้เส้นลูกศรหายไปทั้งหมด

Full Screen Home

 

เอกสารประกอบหลักสูตร Excel Expert Training   
www.tpa.or.th/xlsiam/     http://xls.i.am

03/10/2544